排列五开奖号码走势图|排列五开奖公告
首頁 > 編程學習記錄 > 易語言傳送支持庫:提示“無法獲得文件大小”

201612月20

易語言傳送支持庫:提示“無法獲得文件大小”

作者:admin 0 Comments 發表評論

明明是按照教程來寫的代碼,但是提示“無法獲得文件大小”,然后就沒有然后了,直接停止了下載。測試發現如果是下載MP3、exe等的鏈接沒有問題,但是下載HTML文件時有問題,下面是截圖和代碼:

提示:無法獲取文件大小

http://pan.baidu.com/s/1bpgOQQV

如果不愿意下載,可以直接復制下面的:

.版本 2
.支持庫 downlib
.支持庫 spec

.程序集 窗口程序集_啟動窗口
.程序集變量 下載對象, 下載對象
.程序集變量 配置信息, 任務參數

.子程序 _按鈕1_被單擊

配置信息.類型 = #傳送常量.下載

配置信息.文件地址 = “http://im.qq.com/”
配置信息.本地文件路徑 = “F:\99.html”
配置信息.默認線程數 = 1
配置信息.連接超時 = 20000
配置信息.發送超時 = 20000
配置信息.接收超時 = 20000
配置信息.下載速度 = 0

配置信息.日志回調函數 = &日志回調函數子程序 ‘ 測試可以不用
配置信息.交互回調函數 = &交互回調函數子程序 ‘ 必須要有
下載對象.增加新任務 (配置信息)
.子程序 日志回調函數子程序
.參數 線程信息, 整數型
.參數 消息產生的時間, 文本型
.參數 消息的正文, 文本型
.參數 消息類型, 整數型
.參數 對象信息, 整數型

調試輸出 (消息的正文)
.子程序 交互回調函數子程序
.參數 消息類型, 整數型
.參數 線程信息, 整數型
.參數 第三個參數, 整數型
.參數 第四個參數, 整數型
.參數 對象信息, 整數型
調試輸出 (消息類型)

補充:通過經過進一步測試,如果下載的網頁是純靜態頁面,就可以正常下載,如果是偽靜態或者動態頁面,就不能正常下載,都是提示無法獲取文件大小,然后就停止了下載。用“HTTP讀文件”倒是可以下載正常,但是這樣就沒法獲取到下載進度等信息。

用HTTP下載的方式寫的多線程的源碼:

http://pan.baidu.com/s/1miBEHXe

推薦閱讀相關文章:編程學習記錄

本文地址:http://www.c7hk.com/chuansongzhichiku.html
版權所有 © 轉載時必須以鏈接形式注明作者和原始出處!

本文目前尚無任何評論.

發表評論

排列五开奖号码走势图