排列五开奖号码走势图|排列五开奖公告
首頁 > 編程學習記錄 > 安裝WDCP面板錯誤是因為面板與centos系統不兼容

201702月18

安裝WDCP面板錯誤是因為面板與centos系統不兼容

作者:admin 2 Comments 發表評論

這兩天折騰了linode的VPS ,折騰包括從日本機房換到美國機房,centos5.6換到centos6.5到centos7,WDCP從2.5版本到3.0版本,來回折騰,系統安裝了一遍又一遍,連換機房也換了不下20次,好在linode隨便折騰,一鍵選擇。

在安裝WDCP的過程中出現了多次問題,首先說說源碼安裝方式和RPM包安裝方式,雖然從百度上查詢,都說沒什么區別,但是我個人測試了多次,發現用RPM包安裝都出現了問題,但是用源碼安裝方式就沒有問題的情況。雖然用源碼安裝方式要慢很多,但我個人測試不容易出現各種莫名其妙的問題一些,因此要裝的話,都推薦使用源碼安裝的方式。

另外在安裝的時候出現這樣的提示:

rror: %post(lanmp_wdcp-2-5.x86_64) scriptlet failed, exit status 1

這個問題也在百度上查詢了多個結果,也有不少人問,但是官方貌似沒給出什么答復,只說過可能是版本不兼容,后面我換到了centos5.6然后安裝就沒這個問題了。

另外安裝的版本是WDCP2.5系列的,至于最新的版本3.0,看網上反饋有不少問題,然而官方也沒怎么管,說明官方對這個新版本并沒有投入多大的精力,還是建議使用原來的舊版本。而舊版本在設計的時候,centos的版本還比較低,因此在選擇系統的時候要選擇比較低的版本,這樣才不容易出現各種莫名其妙的問題。

推薦閱讀相關文章:編程學習記錄

本文地址:http://www.c7hk.com/wdcp-centos.html
版權所有 © 轉載時必須以鏈接形式注明作者和原始出處!

2 Responses to “安裝WDCP面板錯誤是因為面板與centos系統不兼容”

  1. #1 樂之屋 回復 | 引用 Post:2017-02-18 21:51

    我用的阿里云,一下就安裝好了,我之前用的是WDCP從2.5版本
    我把系統重新安裝再安裝WDCP3.0版本

    • #2 admin 回復 | 引用 Post:2017-02-19 10:12

      嗯,阿里云的沒問題的,我用的這個linode很詭異,不知道是不是內核不同的原因,安裝銳速也不行。看了他們的內核都是4.*** 的版本。阿里云好是好,但是備案的太麻煩,香港的太貴了。

發表評論

排列五开奖号码走势图